Back to overview
Downtime

Ritual Service Outage

Jul 30 at 02:30pm BST
Affected services
Dashboard
Brands
Links
Music

Resolved
Jul 30 at 02:52pm BST

Service has been restored. We'll continue to monitor the situation.

Updated
Jul 30 at 02:39pm BST

We have identified the cause of the issue. Services are back online but performance may be degraded.

Created
Jul 30 at 02:30pm BST

We are investigating an outage affecting our online services.