Back to overview
Degraded

Mailgun Outage

Feb 23, 2023 at 9:50pm UTC
Affected services
Dashboard
Brands
Links
Music

Resolved
Feb 28, 2023 at 7:05pm UTC

This incident has been resolved

Created
Feb 23, 2023 at 9:50pm UTC

Our email provider is experiencing downtime; we're taking steps to mitigate this issue.